Install Git on Snow Leopard

Posted by on Sep 4, 2009 in Software Tools | 2 comments

To install git on the latest version of OS X (10.6), use the git-1.6.4.2-intel-leopard.dmg (or later) package from git-osx-installer. So far it works fine for me on Snow Leopard.

I like how OS X comes with a large number of open source packages such as PHP, Apache, Vim, Subversion and Ruby on Rails; however, I’d really like to see Apple add Git to the list.

2 Comments

  1. ( I came here via OS News. Why would any distro (lets call that the software outside the kernel) include an SCM software? Perhaps in dev tools along with svn but they’d probibly choose mircural because python and Google and Track (ergo macforge) supports it.

  2. Thank you!

    I just spent a good 2 hours fighting with git on mac os x. Just continued to throw an error. I use git-osx-installer and BAM 2 minutes later I finally have a working git!

    For any others who experience “*** [git-fast-import] Error 1″, you may wish to try it too.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>